Topic-icon Ubuntu Synaptic Package manager

More
25 Jul 2019 02:57 #43794 by KYFHO
KYFHO created the topic: Ubuntu Synaptic Package manager
Ubuntu's Synaptic Package manager still has version 1.1.1-7

Please Log in or Create an account to join the conversation.

More
25 Jul 2019 11:23 #43797 by tahr
tahr replied.
Hi KYFHO,

As far as I know, from Ubuntu 19.04 should install v.1.1.2 . Prior Ubuntu versions still have v.1.1.1

Unless for main/security packages or bugs, I think package maintainers don't usually create packages for old versions.

Regards,
tahr
The following user(s) said Thank You: sp0ck

Please Log in or Create an account to join the conversation.

More
25 Jul 2019 15:52 #43798 by KYFHO
KYFHO replied.
Not everyone updates the distribution every six months, I use the LTS version.
I tried adding a PPA but it game me an error.

Please Log in or Create an account to join the conversation.

More
25 Jul 2019 16:53 - 25 Jul 2019 17:39 #43799 by sp0ck
sp0ck replied.

KYFHO wrote: Not everyone updates the distribution every six months, I use the LTS version.
I tried adding a PPA but it game me an error.


Can you be more specific?

What about downloading the deb files directly from ubuntu packages site?

from Ubuntu 19.04


* pokerth
* pokerth-data

Should be installed manually without any error - `sudo dpkg -i`

EDIT:
doesn't work wo problems because the client is built with newer libraries. You'd have to manually update them all :(
dpkg: dependency problems prevent configuration of pokerth:
 pokerth depends on libboost-filesystem1.67.0; however:
  Package libboost-filesystem1.67.0 is not installed.
 pokerth depends on libboost-iostreams1.67.0; however:
  Package libboost-iostreams1.67.0 is not installed.
 pokerth depends on libboost-random1.67.0; however:
  Package libboost-random1.67.0 is not installed.
 pokerth depends on libboost-regex1.67.0; however:
  Package libboost-regex1.67.0 is not installed.
 pokerth depends on libboost-system1.67.0; however:
  Package libboost-system1.67.0 is not installed.
 pokerth depends on libboost-thread1.67.0; however:
  Package libboost-thread1.67.0 is not installed.
 pokerth depends on libgsasl7 (>= 1.1); however:
  Package libgsasl7 is not installed.
 pokerth depends on libprotobuf17; however:
  Package libprotobuf17 is not installed.
 pokerth depends on libqt5core5a (>= 5.11.0~rc1); however:
  Version of libqt5core5a:amd64 on system is 5.9.5+dfsg-0ubuntu2.1.
 pokerth depends on libqt5widgets5 (>= 5.11.0~rc1); however:
  Version of libqt5widgets5:amd64 on system is 5.9.5+dfsg-0ubuntu2.1.
 pokerth depends on libsdl-mixer1.2; however:
  Package libsdl-mixer1.2 is not installed.
 pokerth depends on libsdl1.2debian (>= 1.2.11); however:
  Package libsdl1.2debian is not installed.
 pokerth depends on libtinyxml2.6.2v5; however:
  Package libtinyxml2.6.2v5 is not installed.

Please Log in or Create an account to join the conversation.

More
26 Jul 2019 02:30 - 26 Jul 2019 02:36 #43807 by KYFHO
KYFHO replied.
Trying to add the PPA:
sudo add-apt-repository ppa:pkg-games/ppa
E: The repository 'http://ppa.launchpad.net/pkg-games/ppa/ubuntu bionic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
Apparently other people are having problems adding certain PPAs. This is not a PokerTH issue.

After downloading the files and trying to run the new version from the command line:
/home/KYFHO/PokerTH-1.1.2/pokerth: error while loading shared libraries: libmysqlclient.so.18: cannot open shared object file: No such file or directory
I think Spock answered this question.

Please Log in or Create an account to join the conversation.

More
26 Jul 2019 13:31 - 27 Jul 2019 18:53 #43808 by sp0ck
sp0ck replied.
Hi KYFHO,

I created a Snap for the 1.1.2 Version. It runs on pretty many distributions inclusive the last LTS.

pokerth_1.1.2_amd64.snap

You might need to install snapd prior:
sudo apt install snapd

Then install the snap:
sudo snap install --devmode pokerth_1.1.2_amd64.snap

Enter
pokerth
in a terminal or click the menu entry to start the client.
The following user(s) said Thank You: KYFHO, tahr

Please Log in or Create an account to join the conversation.

Champions of

PokerTH - live

The PokerTH spectator tool.

Member Login

 advert
NOTE! This site uses cookies and similar technologies.
Cookies make it easier for us to provide you with our services. With the usage of our services you permit us to use cookies.
More information

We use cookies to personalize content and ads to offer features for social media and analyze the number of hits on our website. We also provide information about your use of our website to our partner for social media, advertising and analysis on.
http://www.google.com/intl/de/policies/privacy/partners/